Polly.Extensions.Http by: App vNext
  • 23 total downloads
  • Latest version: 3.0.0
  • HttpClient HttpClientFactory Exception Handling Resilience Transient Fault Policy
Polly.Extensions.Http is an extensions package containing opinionated convenience methods for configuring Polly policies to handle transient faults typical of calls through HttpClient.
Polly.Extensions.Http-Signed by: App vNext
  • 9 total downloads
  • Latest version: 1.0.4
  • HttpClient Exception Handling Resilience Transient Fault Policy
Polly.Extensions.Http is an extensions package containing opinionated convenience methods for configuring Polly policies to handle transient faults typical of calls through HttpClient.
Polly.RateLimiting by: Michael Wolfenden, App vNext
  • 1 total downloads
  • Latest version: 8.7.0
  • Polly Exception Handling Resilience Transient Fault Policy Wait Bulkhead Rate-limit Throttle Hedging
Polly.RateLimiting is a .NET resilience and transient-fault-handling library that allows developers to express resilience strategies using a Rate Limiter in a fluent and thread-safe manner.
PolySharp by: Sergio Pedri
  • 66 total downloads
  • Latest version: 1.15.0+02753db24d9685e54db06739eb63183d86eb5b62
  • dotnet net netcore netstandard csharp library generator polyfill roslyn
PolySharp provides generated, source-only polyfills for C# language features, to easily use all runtime-agnostic features downlevel
Pomelo.EntityFrameworkCore.MySql by: Laurents Meyer, Caleb Lloyd, Yuko Zheng
  • 4 total downloads
  • Latest version: 9.0.0-rc.1.efcore.9.0.0
  • pomelo mysql mariadb Entity Framework Core entity-framework-core ef efcore ef core orm sql
Pomelo's MySQL database provider for Entity Framework Core.
Pomelo.JsonObject by: Pomelo.JsonObject
  • 2 total downloads
  • Latest version: 2.2.1
  • JSON Entity Framework Core entity-framework-core MySQL EF ORM
MySQL provider for Entity Framework Core
Portable.BouncyCastle by: Claire Novotny
  • 222 total downloads
  • Latest version: 1.9.0
  • bouncycastle cryptography encryption security
BouncyCastle portable version with support for .NET 4, .NET Standard 2.0
Portable.BouncyCastle-Signed by: Mark Junker
  • 6 total downloads
  • Latest version: 1.7.0.2
  • bouncycastle, cryptography, encryption, security, PCL, wp8, wpa81, net4, sl5, monotouch, monoandroid, xamarin
BouncyCastle.Crypto is a cryptography API providing: -Generation and parsing of PKCS#12 files. -X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. -PBE algorithms supported by PBEUtil: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. -Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. -Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, DESede, DES, GOST28147, HC-128, HC-256, IDEA, NaccacheStern, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Serpent, Skipjack, TEA/XTEA, Twofish, and VMPC. -Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). -Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS#5/7, TBC, X.923, and Zero Byte. -Asymmetric key algorithms: RSA (with blinding), ElGamal, DSA, ECDSA. -Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS#1. -Digests: GOST3411, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, Tiger, and Whirlpool. -Signer mechanisms: DSA, ECDSA, ECGOST3410, GOST3410, ISO9796d2, PSS, RSA. -Key Agreement: Diffie-Hellman and EC-DH. -Macs: CBCBlockCipher, CFBBlockCipher, GOST28147, HMac, and ISO9797 Alg. 3. -PBE generators: PKCS#12, and PKCS#5 - schemes 1 and 2. -OpenPGP (RFC 2440) -Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. -Online Certificate Status Protocol (OCSP, RFC 2560). -Time Stamp Protocol (TSP, RFC 3161). -TLS/SSL Client with support for client side authentication. Support for .NET 4, Windows Phone 8, Windows Phone App 8.1, Windows 8, Silverlight 5, MonoTouch, MonoAndroid
Portable.ConcurrentDictionary by: Stef Heyenrath
  • 8 total downloads
  • Latest version: 1.0.4
  • Dictionary ConcurrentDictionary Collections System.Collections.Concurrent
This is a .NET Standard 1.0, .NET 2.0, .NET 3.5, Silverlight 5.0 and Windows Phone Silverlight 8.0 & 8.1 backport from System.Collections.Concurrent.ConcurrentDictionary as defined in .NET Core
Portable.DataAnnotations by: Ryan Horath
  • 2 total downloads
  • Latest version: 1.0.0
  • net45 win8 net40 netcore45 sl5 wp8 wpa81 dataannotations data annotations
A portable library for the DataAnnotations namespace. Reduced surface area matches the Silverlight SDK version of DataAnnotations, with additions of some classes.
prometheus-net by: andrasm, qed-, lakario, sandersaares
  • 489 total downloads
  • Latest version: 8.2.1
  • metrics prometheus
.NET client library for the Prometheus monitoring and alerting system
prometheus-net.AspNetCore by: andrasm, qed-, lakario, sandersaares
  • 589 total downloads
  • Latest version: 8.2.1
  • metrics prometheus aspnetcore
ASP.NET Core middleware and stand-alone Kestrel server for exporting metrics to Prometheus
protobuf-net by: Marc Gravell
  • 3 total downloads
  • Latest version: 3.4.21
  • binary serialization protobuf
Provides simple access to fast and efficient "Protocol Buffers" serialization from .NET applications
protobuf-net.Core by: Marc Gravell
  • 88 total downloads
  • Latest version: 3.3.0-g6785ecbb35
  • binary serialization protobuf
Provides simple access to fast and efficient "Protocol Buffers" serialization from .NET applications
protobuf-net.Grpc by: Marc Gravell
  • 102 total downloads
  • Latest version: 1.2.2
  • grpc
Package Description
protobuf-net.Grpc.AspNetCore by: Marc Gravell
  • 89 total downloads
  • Latest version: 1.2.2
  • grpc
Package Description
protobuf-net.Grpc.ClientFactory by: Marc Gravell
  • 56 total downloads
  • Latest version: 1.2.2
  • grpc
Package Description
PuppeteerSharp by: Darío Kondratiuk
  • 1 total downloads
  • Latest version: 25.2.1
  • headless,chrome,puppeteer
Headless Browser .NET API
QRCoder by: Raffael Herrmann, Shane Krueger
  • 1 total downloads
  • Latest version: 1.8.0
  • c# csharp qr qrcoder qrcode qr-generator qr-code-generator
QRCoder is a simple library, written in C#.NET, which enables you to create QR codes.
RabbitMQ.Client by: Broadcom
  • 106 total downloads
  • Latest version: 7.2.0
  • rabbitmq, amqp
The RabbitMQ .NET client is the official client library for C# (and, implicitly, other .NET languages)